His example shows a class named
List with a method of
This would be pretty sweet and has been, at times, something that has frustrated me when I’ve wanted a method
called something like
list, but had to go with
getList() instead due to
list being a reserved word.
The only problem with this implementation is that it leads to a lot of ambiguity and unintended consequences, such
as writing a function named
list and then not knowing if the one should call the built-in
list or the user
I’m very interested to see where this goes. I’d definitely support it in the case of Class and Method names.